Maintenance on August 23rd, 2019
Incident Report for PrimeXBT Trading Platform
Resolved
Dear users, platform maintenance has been completed.
Thank you for your patience.
Posted Aug 23, 2019 - 22:43 UTC
Identified
The issue has been succesfully identified. All unaffected users can now access the platform. All users with orders executed (or liquidations) during the trading engine disruption will not be able to access the account until all positions / orders are restored and compensations take place.
Posted Aug 23, 2019 - 10:12 UTC
This incident affected: Web Trading Platform (Global Markets trading platform) and Mobile app for margin trading, Deposits and Withdrawals.