Trading service minor disruptions
Incident Report for primexbt
Resolved
Dear users, the incident has been resolved.
Thank you for your patience.
Posted 8 months ago. Feb 22, 2019 - 12:06 UTC
Identified
We observe irregular accessibility issues on the trading platform. Some users may experience problems loading Trade page. Refreshing the page in the browser helps in this case.
Also, internal transfers between Wallet and Trading Account may be affected. Please check your Wallet and Trading Account balances after making an internal transfer to ensure its successful completion.
Our team is working on fixing the issue.
All client's funds are safe. Trading is available as long as Trade page loads for you.
We will update the status as soon as the issue is permanently resolved.
Posted 8 months ago. Feb 22, 2019 - 11:45 UTC
This incident affected: Prime XBT Trading Platform (Trading, Deposits and Withdrawals).