Trading service disruption
Incident Report for PrimeXBT Trading Platform
Resolved
The incident has been resolved. The trading platform is fully operational now
Posted Apr 20, 2020 - 21:27 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 20, 2020 - 18:48 UTC
Monitoring
The trading platform is operational now.
Some users may experience Account status page not loading. If you need to fund your Trading account from Wallet and encounter this issue, you can still access Fund Trading account dialogue from Account's menu in the top-right corner of Account summary page.
Our team is working to resolve the issue. Thank you for your patience
Posted Apr 20, 2020 - 18:48 UTC
Investigating
We observe accessibility issues on the trading platform. Some users may experience problems loading TRADE page for margin trading.
TURBO is not affected by the incident.

Our team working on it to fix it as soon as possible
Posted Apr 20, 2020 - 17:55 UTC
This incident affected: Web Trading Platform (Global Markets trading platform) and Deposits and Withdrawals.