Trading Platform Accessibility Issues
Incident Report for PrimeXBT Trading Platform
Resolved
The incident has been resolved. PrimeXBT trading platform and site are fully operational now.
Posted Jul 02, 2019 - 15:48 UTC
Monitoring
Dear users, the issue has been addressed. PrimeXBT site and user accounts are fully accessible now.
We continue to monitor the service performance.
Thank you for your patience.
Posted Jul 02, 2019 - 14:38 UTC
Identified
We currently observe issues with accessibility to PrimeXBT site and user accounts, due to service disruption of one of world-wide service providers. Our team is working to resolve the issue and restore access to the platform.
All client's funds are safe. We will update the status as soon as the issue is permanently resolved.
Posted Jul 02, 2019 - 14:07 UTC
This incident affected: Web Trading Platform (Global Markets trading platform) and Deposits and Withdrawals, Main Site.