Price quotes are being delayed for Crypto markets
Incident Report for PrimeXBT Trading Platform
Resolved
Extended monitoring has been finished. The issue with the price quotes is confirmed to be resolved
Posted Feb 14, 2023 - 15:57 UTC
Monitoring
The price quote feed has been restored for all instruments. We are monitoring the system to ensure its optimal performance
Posted Feb 14, 2023 - 11:56 UTC
Investigating
We are currently observing an issue with price quotes for Crypto markets from one of our liquidity providers. The price quotes may be delayed.

Forex, Indices, and Commodities markets are not affected by this outage.

Because of the issue, users may experience order execution delays or rejections when trading Crypto markets due to missing quotes.

We are aware of the issue and are currently working with our liquidity provider to restore the price feed as soon as possible. We are looking into it as a priority and should fix it in the nearest time
Posted Feb 14, 2023 - 11:27 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module, In-wallet Currency Exchange) and Mobile app for margin trading.