Trading Platform Accessibility Issues
Incident Report for PrimeXBT Trading Platform
Resolved
The issue has been resolved. The trading platform is fully accessible now
Posted Sep 29, 2023 - 12:14 UTC
Investigating
We observe accessibility issues to PrimeXBT trading platform. We have taken the trading platform offline for a short maintenance to address the issues. Our team is working on restoring access to the platform as soon as possible.

We will update the status as soon as the problem is permanently resolved.
Posted Sep 29, 2023 - 11:46 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module, In-wallet Currency Exchange, Crypto Futures trading platform) and Mobile app for margin trading, Deposits and Withdrawals.