Trading platform accessibility issues
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 09:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2024 - 08:50 UTC
Investigating
We observe accessibility issues to PrimeXBT trading platform. We have taken the trading platform offline for a short maintenance to address the issues. Our team is working on restoring access to the platform as soon as possible.

We will update the status as soon as the problem is permanently resolved.
Posted Feb 06, 2024 - 07:56 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module, In-wallet Currency Exchange, Crypto Futures trading platform) and Mobile app for margin trading, Deposits and Withdrawals.