Trade service disruption
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Jun 28, 2021 - 17:15 UTC
Monitoring
We have implemented the fix. The Trade terminal and the platform are fully online and functional now.
We are monitoring the platform to ensure its optimal performance
Posted Jun 28, 2021 - 16:40 UTC
Update
Please use the mobile app to manage positions on a Margin or Covesting Strategy account, while we continue investigating the issue.
Posted Jun 28, 2021 - 16:12 UTC
Investigating
We observe issues with the accessibility of the Trade terminal. The Trade terminal may not load and re-load periodically without completing the loading.

Our team is working to identify the issue and fix it as soon as possible
Posted Jun 28, 2021 - 16:09 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module).