Margin Trading service disruption
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 10:02 UTC
Monitoring
Margin Trading service accessibility has been restored. We are now monitoring the platform to ensure its stability.
Thank you for your patience.
Posted Jul 01, 2020 - 09:39 UTC
Update
We are continuing to investigate this issue.
Posted Jul 01, 2020 - 09:24 UTC
Investigating
We observe accessibility issues on the trading platform. Some users may experience problems loading TRADE page for Margin trading.

TURBO service are not affected by the incident.

Our team working on it to fix it as soon as possible
Posted Jul 01, 2020 - 09:24 UTC
This incident affected: Web Trading Platform (Margin Trading) and Mobile app for margin trading.