Trading service disruption
Incident Report for PrimeXBT Trading Platform
Resolved
We have identified and fixed the trading service issue. The platform is operational now.

The users may temporarily observe the trading records for the past two days to be missing in the trading history. Full trading history is always available in Trading report / Account statement.

Covesting managers may temporarily lose some achievement badges on their Strategies.

This information does not affect the trading and will be fully restored in the next few hours.
Posted Mar 19, 2021 - 13:47 UTC
Update
We are taking the platform to additional maintenance to implement the fixes.
Thank you for your patience. Stay updated on the platform status: https://status.primexbt.com
Posted Mar 19, 2021 - 13:12 UTC
Identified
The main issue has been identified and a fix is being implemented.
The Trade interface is available now. Some users may observe account status stats not being available.
Our team is working on fixing the remaining issues.
Posted Mar 19, 2021 - 13:06 UTC
Investigating
We observe accessibility issues on the trading platform. We have taken the platform offline for maintenance to address the issue.

Our team working on it to fix it as soon as possible
Posted Mar 19, 2021 - 12:38 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module) and Mobile app for margin trading, Deposits and Withdrawals.