Service unavailable for most of the users
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Mar 21, 2021 - 17:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results
Posted Mar 21, 2021 - 17:35 UTC
Investigating
The service is unavailable now for most of the users. Our team is looking into it to bring the platform online as soon as possible

Please stay updated on the platform status at https://status.primexbt.com
Posted Mar 21, 2021 - 17:26 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module) and Mobile app for margin trading, Deposits and Withdrawals.