Trading service disruption
Incident Report for PrimeXBT Trading Platform
Resolved
Dear users, the issue has been addressed. Trade page and user Account statuses are fully accessible now.
Thank you for your patience.
Posted Apr 15, 2020 - 04:58 UTC
Update
We are continuing to investigate this issue.
Posted Apr 15, 2020 - 03:42 UTC
Investigating
We observe accessibility issues on the trading platform. Some users may experience problems loading Trade page. Our team working on it to fix it as soon as possible
Posted Apr 15, 2020 - 03:41 UTC
This incident affected: Web Trading Platform (Margin Trading, Turbo) and Mobile app for margin trading, Deposits and Withdrawals, Main Site.