Turbo service disruption
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 15:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2020 - 14:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 31, 2020 - 14:07 UTC
Investigating
We observe issues with Turbo service availability. Some users may experience problems loading price charts on Turbo accounts or opening positions in Turbo.

Our team working on it to fix it as soon as possible
Posted Jul 31, 2020 - 14:04 UTC
This incident affected: Web Trading Platform (Turbo).