Messages cannot be sent via support chat messenger
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 11:15 UTC
Identified
We observe issues with our support chats. Messages in new chats are not delivered to our support team.
If you need to contact support while we are working on this issue, please send a message to email support@help.primexbt.com, or continue one of your older chats with support instead of opening a new one.
Posted Feb 22, 2024 - 08:14 UTC
This incident affected: Support Chat.