Mobile app keeps loading
Incident Report for PrimeXBT Trading Platform
Resolved
The issue with mobile app has been resolved
Posted Dec 11, 2021 - 12:41 UTC
Investigating
Users of PrimeXBT app on Android devices and the old iOS app may experience an issue with continuous app loading after login. We are investigating it.

For iOS users, we recommend installing our new app: it has been improved significantly and has more features.
For Android users, we recommend to use web version of the platform as a workaround if there is an issue with loading.
Posted Dec 11, 2021 - 11:29 UTC
This incident affected: Mobile app for margin trading.