Withdrawals over TRON network (TRC-20) may be delayed
Incident Report for PrimeXBT Trading Platform
Resolved
We have completed checks of the TRON network withdrawal processing. All pending TRC-20 withdrawals due today have been processed and released.
Posted Jul 11, 2023 - 16:03 UTC
Identified
Following the TRON network upgrade (Periander upgrade), PrimeXBT is additionally verifying and monitoring withdrawals over the TRON network (TRC-20) to ensure a smooth transition and safety of clients’ transactions after the network upgrade.

Due to the additional verification, withdrawals over the TRON network (TRC-20) may be delayed on Tuesday, July 11th, 2023.

Withdrawals over other blockchains - Bitcoin, Ethereum (ERC-20), BSC (BEP-20), - and deposits over all blockchains are not affected by this additional check.

We will notify additionally once the verification is completed.
Posted Jul 11, 2023 - 12:37 UTC
This incident affected: Deposits and Withdrawals.