Maintenance on September 3rd, 2019
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Sep 03, 2019 - 17:12 UTC
Monitoring
We have completed the maintenance. The platform is back online.
Thank you for your patience
Posted Sep 03, 2019 - 15:48 UTC
Investigating
Dear PrimeXBT users,
We have taken PrimeXBT platform for maintenance to address an issue with platform accessibility. We are working to fix it as soon as possible. All client funds are safe and unaffected
Posted Sep 03, 2019 - 15:37 UTC
This incident affected: Web Trading Platform (Margin Trading, Turbo) and Mobile app for margin trading, Deposits and Withdrawals.