Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 09, 2025 - 08:15 UTC
Scheduled
Dear Traders! Your experience is our priority. To continue improving our platform, we will be performing scheduled maintenance on April 9 at 08:15 GMT for approximately one hour. While we don't expect any downtime, some services may run slower during this period. We appreciate your support and patience as we work to make your trading experience even better.
Posted Apr 08, 2025 - 13:19 UTC
This scheduled maintenance affected: Mobile app for margin trading, Deposits and Withdrawals, and Main Site.