Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 08, 2025 - 07:00 UTC
Scheduled
Dear Traders! On the 8 of February at 7:00 GMT, we will be performing scheduled maintenance of CFD Platform.The maintenance is expected to last approximately 30 minutes. During this period, all CFD products will be unavailable, and traders will not be able to open or close any positions. We appreciate your understanding and cooperation as we work to enhance the platform's performance.
Posted Feb 05, 2025 - 14:26 UTC
This scheduled maintenance affected: Web Trading Platform (CFD trading platform).