Mobile app connectivity issues
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Aug 25, 2020 - 15:45 UTC
Monitoring
A fix has been implemented. The mobile app is fully operational now.
We are monitoring the results
Posted Aug 25, 2020 - 15:29 UTC
Investigating
Some users may experience connectivity issues with the mobile app (iOS and Android): the app would fail to load trading interface and display 'connection failed' error.

Web trade interface is not affected by the issue and is fully available for trading.

Our team working on mobile app connection issue to fix it as soon as possible
Posted Aug 25, 2020 - 15:05 UTC
This incident affected: Mobile app for margin trading.