Trading service disruption
Incident Report for primexbt
Resolved
Dear users, the issue has been addressed. PrimeXBT site and user accounts are fully accessible now.
We continue to monitor the service performance.
Thank you for your patience.
Posted Oct 08, 2019 - 18:08 UTC
Identified
We observe irregular accessibility issues on the trading platform. Some users may experience problems loading Trade page. Our team working on it to fix it as soon as possible
Posted Oct 08, 2019 - 18:00 UTC
This incident affected: Prime XBT Trading Platform (Trading).