Trading Platform Accessibility Issues
Incident Report for primexbt
Resolved
The incident has been resolved. PrimeXBT trading platform and site are fully operational.
Posted 12 days ago. Jul 05, 2019 - 12:30 UTC
Monitoring
Dear users, the issue has been addressed. User accounts are fully accessible now.
We continue to monitor the service performance.
Thank you for your patience.
Posted 12 days ago. Jul 05, 2019 - 00:17 UTC
Investigating
Users may experience issues logging in to PrimeXBT accounts, or being forcefully logged off. Our team is working to resolve the issue and restore access to the platform.
All client's funds are safe. We will update the status as soon as the issue is permanently resolved.
Posted 12 days ago. Jul 04, 2019 - 23:05 UTC
This incident affected: Prime XBT Trading Platform (Trading, Deposits and Withdrawals, Client Account Info).