Price quotes are being delayed
Incident Report for PrimeXBT Trading Platform
Resolved
We have finished extended monitoring of the platform performance. The platform's fully operational status is confirmed.
Posted Mar 29, 2023 - 16:03 UTC
Monitoring
The issue with the price quotes feed has been resolved. We are monitoring the platform to ensure its performance.
Posted Mar 29, 2023 - 15:49 UTC
Investigating
We are currently observing an issue with price quotes from one of our liquidity providers. The price quotes are being delayed for Forex and CFDs instruments.

Because of the issue, users may experience order execution rejections due to missing quotes.

We are aware of the issue and are currently working with our liquidity provider to restore the price feed as soon as possible. We are looking into it as a priority and should fix it in the nearest time
Posted Mar 29, 2023 - 15:42 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module, In-wallet Currency Exchange) and Mobile app for margin trading, Deposits and Withdrawals.