Maintenance on August 23rd, 2019
Incident Report for PrimeXBT Trading Platform
Resolved
Dear users, platform maintenance has been completed.
Thank you for your patience.
Posted Aug 23, 2019 - 10:07 UTC
Identified
Dear PrimeXBT users,
We have taken PrimeXBT platform for maintenance to address an inconsistency in liquidity aggregation. We are addressing the issue at the moment and will be back online shortly. All client funds are safe and unaffected
Posted Aug 23, 2019 - 07:07 UTC
This incident affected: Web Trading Platform (Global Markets trading platform) and Mobile app for margin trading, Deposits and Withdrawals.