Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 27, 2024 - 08:00 UTC
Scheduled
Dear customers, Scheduled maintenance will take place on the platform from 08:00 to 09:00 UTC on November 27, 2024. We apologize for any inconvenience caused.
Posted Nov 27, 2024 - 07:57 UTC
This scheduled maintenance affected: Mobile app for margin trading, Deposits and Withdrawals, and Main Site.