Service accessibility issues
Incident Report for PrimeXBT Trading Platform
Resolved
Dear users, the issue has been addressed. PrimeXBT site and user accounts are fully accessible now.
We continue to monitor the service performance.
Thank you for your patience.
Posted Mar 12, 2020 - 15:55 UTC
Investigating
We currently observe irregular accessibility issues in the mobile app and account’s web interface.
Some users may experience the mobile app not going past Loading screen upon login. Trading account info and Account Status may not be loading on Account summary page, which may prevent users from funding Trading account and withdrawing funds from it. Redeeming promocodes on Promocode page may not be available and throw error message upon an attempt to activate a code.

Our team is working on fixing the issue.
All client's funds are safe. You will be able to activate Promocodes again once the issue is resolved. Trade page is not affected and Trading is available.
We will update the status as soon as the issue is permanently resolved.
Posted Mar 12, 2020 - 15:24 UTC
This incident affected: Web Trading Platform (Turbo) and Mobile app for margin trading.