Partial outage for CFD and Crypro Futures Trading Platform
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 14:32 UTC
Investigating
We are currently investigating this issue.
Posted Jul 22, 2024 - 14:26 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Crypto Futures trading platform).