Trading service disruption
Incident Report for PrimeXBT Trading Platform
Resolved
Dear users, the issue has been addressed. PrimeXBT site and user accounts are fully accessible now.
We continue to monitor the service performance.
Thank you for your patience.
Posted Mar 19, 2020 - 22:53 UTC
Identified
We observe accessibility issues on the trading platform. Some users may experience problems loading Trade page. Our team working on it to fix it as soon as possible
Posted Mar 19, 2020 - 21:17 UTC
This incident affected: Web Trading Platform (Global Markets trading platform) and Mobile app for margin trading.