Price quote delays for FX, Indices, and Commodities
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 11:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2021 - 11:11 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 18, 2021 - 11:04 UTC
Investigating
We observe delays receiving price quotes from our liquidity provider for FX, Indices, and Commodities markets. As an STP broker, we depend on liquidity providers to quote prices and fill client orders that we pass to them directly for execution. Limit and stop orders will be filled at the first available quote, a market order may be rejected if there is no price quote to fill it.

We work with the liquidity provider to resolve the issue with the quote feed as soon as possible.
Posted Jun 18, 2021 - 10:56 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module).