Margin Trading service disruption - Personal accounts and Covesting Strategies
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Mar 11, 2021 - 17:59 UTC
Investigating
We observe accessibility issues on the trading platform. Some users may experience problems loading TRADE page for Margin trading and Covesting Strategies.

Margin trading in iOS and Android app, and TURBO service are not affected by the incident.

Our team working on it to fix it as soon as possible
Posted Mar 11, 2021 - 17:44 UTC
This incident affected: Web Trading Platform (Margin Trading, Covesting).