Maintenance on April 11th, 2019
Incident Report for primexbt
Resolved
The maintenance is completed. Thank you for your patience
Posted 6 months ago. Apr 11, 2019 - 12:38 UTC
Identified
Dear PrimeXBT users,
We have taken PrimeXBT platform for a short maintenance which is related to our recent release. The release was aimed to improve platform performance for the users, although it caused inconsistency in account summary section of some user accounts. We are addressing the issue at the moment and will be back online shortly. All client funds are safe and unaffected
Posted 6 months ago. Apr 11, 2019 - 12:15 UTC
This incident affected: Prime XBT Trading Platform (Trading, Deposits and Withdrawals, Client Account Info).