Margin Trading service disruption
Incident Report for PrimeXBT Trading Platform
Resolved
This incident has been resolved.
Posted Aug 25, 2020 - 14:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2020 - 13:49 UTC
Investigating
We observe accessibility issues on the trading platform. Some users may experience problems loading TRADE page for their Margin trading account and/or Covesting Strategy account. Android and iOS mobile app for margin trading may fail to connect.

TURBO service are not affected by the incident.

Our team working on it to fix it as soon as possible
Posted Aug 25, 2020 - 13:29 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module) and Mobile app for margin trading.