Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 07, 2024 - 07:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 06, 2024 - 16:07 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 06, 2024 - 13:27 UTC
Scheduled
Please be advised that on Saturday, September 7th, 2024, starting at 07:00 UTC, the trading platform will undergo maintenance for up to 1 hour. During this time, the platform will be unavailable to users
Posted Sep 06, 2024 - 13:26 UTC
This scheduled maintenance affected: Web Trading Platform (Global Markets trading platform, Copy-trading module, In-wallet Currency Exchange, Crypto Futures trading platform) and Mobile app for margin trading, Deposits and Withdrawals.