Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 30, 2025 - 08:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 29, 2025 - 13:48 UTC
Scheduled
Dear Traders! On the 30 of January at 8:00 GMT, we will be performing scheduled maintenance for approximately one hour and a half. While we do not anticipate any downtime, some services may experience slower performance during this time. We appreciate your understanding and thank you for your patience.
Posted Jan 29, 2025 - 13:47 UTC
This scheduled maintenance affected: Web Trading Platform (Global Markets trading platform, Copy-trading module, In-wallet Currency Exchange, Crypto Futures trading platform) and Mobile app for margin trading, Deposits and Withdrawals, Main Site.