PXTrader Trading Issue

Incident Report for PrimeXBT Trading Platform

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 16:06 UTC

Identified

We’re currently experiencing an issue on the PXTrader platform in the mobile apps, and trading is temporarily unavailable. Our team is working urgently to resolve the problem. In the meantime, we recommend using the web platform primexbt.com, which is currently functioning normally. We apologize for the inconvenience
Posted Dec 11, 2025 - 15:41 UTC
This incident affected: Mobile app for margin trading.