Cloudflare Network Performance Issues in APAC region
Incident Report for PrimeXBT Trading Platform
Resolved
Cloudflare reported the incident with their infrastructure as resolved. We confirm that PrimeXBT site is fully accessible in APAC and SAM regions
Posted May 31, 2023 - 09:46 UTC
Identified
Cloudflare reported network performance issues in the APAC (Asia-Pacific) and SAM (South American) regions as of May 31, 2023 - 07:32 UTC. PrimeXBT utilizes Cloudflare infrastructure to provide access to the trading platform globally. Because of the incident, our users in the APAC region may experience issues loading the web version of the platform.

If you experience issues loading the web version of the platform, we recommend using PrimeXBT mobile app to access your account.

We are monitoring the situation with Cloudflare services
Posted May 31, 2023 - 07:45 UTC
This incident affected: Web Trading Platform (Global Markets trading platform, Copy-trading module, In-wallet Currency Exchange).