Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 23, 2025 - 06:00 UTC
Scheduled
Dear Traders, Your experience is our top priority. To further improve our platform, we will be performing scheduled maintenance on August 23 at 06:00 GMT for approximately 3 hours. During this time, all platform services will be unavailable - including login, logout, trading, deposits, withdrawals, and all other operations on both web and mobile apps. Please make sure to complete any necessary actions, such as opening or closing positions, deposits, or withdrawals, before the maintenance begins. We appreciate your patience and understanding as we work to enhance your trading experience.
Posted Aug 22, 2025 - 08:40 UTC
This scheduled maintenance affected: Mobile app for margin trading, Deposits and Withdrawals, Main Site, and Support Chat.